Terug naar overzicht
Opgelost

Furxenity Backend en Download Server zijn offline

Jul 28, 2026 at 5:24am UTC
Getroffen services
Furxenity Backend
Download Server

Opgelost
Jul 28, 2026 at 10:13pm UTC

Furxenity Backend is hersteld.

Bijgewerkt
Jul 28, 2026 at 10:04pm UTC

Furxenity Backend is offline gegaan.

Bijgewerkt
Jul 28, 2026 at 5:31am UTC

Download Server is hersteld.

Aangemaakt
Jul 28, 2026 at 5:24am UTC

Download Server is offline gegaan.