Terug naar overzicht
Opgelost

Furxenity CDN en Download Server zijn offline

Jul 17, 2026 at 10:21am UTC
Getroffen services
Furxenity CDN
Download Server

Opgelost
Jul 17, 2026 at 11:57am UTC

Download Server is hersteld.

Bijgewerkt
Jul 17, 2026 at 11:48am UTC

Download Server is offline gegaan.

Bijgewerkt
Jul 17, 2026 at 10:37am UTC

Furxenity CDN is hersteld.

Aangemaakt
Jul 17, 2026 at 10:21am UTC

Furxenity CDN is offline gegaan.