Terug naar overzicht
Opgelost

Furxenity Backend is offline

Jul 2, 2026 at 11:52am UTC
Getroffen services
Furxenity Backend

Opgelost
Jul 2, 2026 at 12:01pm UTC

Furxenity Backend is hersteld.

Aangemaakt
Jul 2, 2026 at 11:52am UTC

Furxenity Backend is offline gegaan.