Terug naar overzicht
Opgelost

Furxenity Backend is offline

Jul 1, 2026 at 3:33pm UTC
Getroffen services
Furxenity Backend

Opgelost
Jul 1, 2026 at 3:40pm UTC

Furxenity Backend is hersteld.

Aangemaakt
Jul 1, 2026 at 3:33pm UTC

Furxenity Backend is offline gegaan.